Mengatasi aaPanel tidak bisa install SSL dan tidak bisa update

Berikut panduan cara mengatasi aaPanel tidak bisa install SSL dan tidak bisa update. Kira-kira kalau lihat log di server seperti ini:

ERROR: Could not find a version that satisfies the requirement cffi==1.12.3 (from versions: none)
ERROR: No matching distribution found for cffi==1.12.3
From cffi callback <function _verify_callback at 0x7f42b9dee140>:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/OpenSSL/SSL.py", line 309, in wrapper
    _lib.X509_up_ref(x509)
AttributeError: 'module' object has no attribute 'X509_up_ref'
Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError(SSLError("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')],)",),)) - skipping

Yang pertama kita harus uninstall pyopenssl kemudian upgrade pip

1. Uninstall pyopenssl

pip uninstall pyopenssl

2. Install kembali pyopenssl

pip install pyopenssl

3. Upgrade pip

pip install --upgrade pip

4. Update dan Fix aaPanel dari dashboard

Untuk menguji, coba login ke dashboard aaPanel, dan lakukan:

  • Klik tombol Update di pojok kanan atas, pastikan fitur update tersebut berfungsi.
  • Kemudian, klik tombol Fix, tunggu dan pastikan sampai proses selesai.

Kemudian coba generate sertifikat SSL domain kembali.

Selesai, jika kesulitan silahkan kontak idnetter.com Jasa fix VPS profesional dengan harga terjangkau.

One thought on “Mengatasi aaPanel tidak bisa install SSL dan tidak bisa update

Add a comment